VIDOS Server
Installation and Operating Manual
Contents

Chapter 1 Introduction 3
    About this manual ............................................. 3
    VIDOS Server ................................................. 4

Chapter 2 Installation and Starting 5
    Installation ..................................................... 5
    Starting the program ......................................... 6
    License ......................................................... 7

Chapter 3 Setting up the Server 9
    The server system concept ................................. 9
    Configuration using the Configuration Manager .......... 11

Chapter 4 User Administration 13
    Groups ......................................................... 13
    Users ......................................................... 16

Chapter 5 Server Administration 19
    Server ......................................................... 20
    User administration server ................................ 21
    Backup server ............................................... 22

Chapter 6 Logging 23

Chapter 7 Device Administration 25
    Device assignment ........................................... 25
    Privileges ..................................................... 26

Chapter 8 Information on Working on the Client 29
    Local access .................................................. 29

Chapter 9 Contacts and Service (Address) 31
    Contact address ............................................... 31
    Service and support ......................................... 32

Index 33
Introduction

About this manual

This manual is intended for persons who will configure a VIDOS client/server system. The manual describes how to set up the VIDOS Server program component.

This document assumes that you are familiar with the VIDOS system and with the VIDOS and Configuration Manager programs.

Conventions in this manual

The following symbols and notations highlight important situations and information:

⚠️ **Warning!**

Security instructions where non-compliance can result in loss of data are marked with this symbol.

🔍 **Note**

This symbol indicates special features and provides tips and information for easier, more convenient use of the software.

Terms that you can find in the program, e.g. menu options or commands, are written in **bold**.

References to other documents or other points in this document are written in **SMALL CAPITALS**.

If you have any questions about the programs from the VIDOS Pro Suite, you can find further information on the Internet at:

[www.vidos.net](http://www.vidos.net)

There, you will also find information about new releases or manual versions. You can also submit your suggestions and comments relating to this document so that these can be taken into account for future editions.
VIDOS Server

VIDOS Server is responsible for the central administration of users and devices in a VIDOS system. A central logging database can be created on the server.

The program can be installed on additional PCs, where it acts as a backup server.

In a VIDOS system that is set up with one or more servers, the intention is that users and devices will no longer be managed locally on VIDOS client PCs.

System requirements for operation of VIDOS Server:

- Operating system: Windows XP Professional/Windows 2003 Server
- CPU: Minimum Pentium IV, 2.0 GHz
- RAM: Minimum 256 MB
- Graphics card: VGA or SVGA compatible
- Network adapter: 100 MBit
- Software: DirectX 9.0c
- Hard disk space: 75 MB (for installation)

Additional documentation

VIDOS Server is part of the VIDOS Pro Suite software package. Depending on the configuration of your system, the following documentation may also be useful:

- Configuration Manager: This configuration program is part of every VIDOS Server installation.
- VIDOS: You will need to purchase licenses for these components of the VIDOS Pro Suite according to your requirements. Each program is explained in a separate document.
- VIDOS Lite Viewer
- VIDOS Archive Player & Exporter
- VIDOS Monitor Wall
- Camera documentation: You obtain separate documentation for each camera from the manufacturer.
- VideoJet, VIP, etc.
- NVR: You obtain documentation for each device from Bosch. This explains the typical device settings.
Installation and Starting

Installation

VIDOS Server is installed as a component of the VIDOS Pro Suite software package. The program CD comes complete with installation instructions (QUICK INSTALLATION GUIDE).

VIDOS Server is typically installed on a PC on which no other VIDOS programs (except Configuration Manager) are installed.

VIDOS Server requires the operating system Windows XP Professional or Windows 2003 Server.

VIDOS Server can be installed on additional PCs if required. These then act as a backup server. A backup server provides the user and device configuration in the system if the main server breaks down or the connection fails.

VIDOS Server is set up using Configuration Manager.

In order to be able to connect a VIDOS client PC to the server, the IP address of the server PC is entered in VIDOS (Global settings, for details refer to the documentation for VIDOS).
Starting the program

VIDOS Server is a service that is automatically started along with the computer's operating system.

If the service is not started automatically, proceed as follows:

1. Right-click on the **My Computer** icon on the PC's desktop. Select **Manage** from the popup menu.
   You will see the **Computer Management** window.

2. Click on **Services and Applications** to expand the entry.

3. Click on **Services**.
   All services will be listed on the right-hand side of the window.

   **Note**
   Alternatively: **Control Panel > Administrative Tools > Services**

4. Find the entry for **Vidos Server**.

   **Note**
   If the **Vidos Server** service is not listed, VIDOS Server is not installed.

5. Right click on the **Vidos Server** entry and select **Start** or **Restart**.
   To view the properties of a service, right click on it and select **Properties** from the popup menu. Alternatively, you can set whether the service is automatically or manually started and deactivated.
License

After installation, the program initially runs as a demo version for a period of 30 days.

To activate a function that requires a license, you must generate activation keys. This can be done online at www.vidos.net. To do this, you will require:

- The serial number of your VIDOS Server
- The installation codes, which are displayed in the License Viewer after installing VIDOS Server (see below for details)
- The authentication code, which you will receive from your sales partner after purchasing the required licenses

Alternatively, you can ask your sales partner to generate the activation keys. To do this, give them the installation codes and the serial number and inform them which license you require.

As for all programs in the VIDOS Pro Suite, the licenses for VIDOS Server are managed using the License Viewer.

There are various ways to open the License Viewer:

- On the server PC, click on Start > All Programs. Under VIDOS you will find the option VIDOS Server License Management.
- In Configuration Manager on the server PC, click on Help > About…. Then select the License tab and click on License Viewer.

The License Viewer window displays the Installation Codes.

**Note**

If you require further information, click on Help in the License Viewer window.

You need a corresponding license for each PC on which you will be using the program. VIDOS Activation codes are linked to the respective computer hardware and cannot be used on other PCs.
Setting up the Server

A VIDOS Server is set up using the Configuration Manager. By default, this program is installed along with VIDOS Server. A corresponding icon can be found on your desktop or in the Start menu in the VIDOS program group.

The server system concept

In a VIDOS system, the server is responsible for the administration of:

- Users and their authorizations
- Devices

Administration of these resources cannot be accessed from a VIDOS client.

Additional servers can be set up in a system.
A VIDOS client that is integrated into a server system no longer provides local user administration. The license for such a client differs from the license for a stand-alone VIDOS PC that is operated without server support.

**Upgrades**

To expand existing VIDOS systems with a server to become a client/server application, it is not necessary to set up client licenses for the VIDOS workstations. Each licensed VIDOS workstation automatically has access to a server and can operate as a client. This enables simple and fast migration.

**Users in the server system**

Users are created on the server using Configuration Manager. Only users that have been set up on the server can log in on the VIDOS client. The only exception to this is the user admin, who always has local access to the VIDOS client.

**Devices in the server system**

Authorizations for each device and each camera are specified separately for individual user groups on the server. In the system, users can only see the devices for which they have been assigned the corresponding authorization.

**Server connection information**

To edit the configuration of the server, you must use the Configuration Manager to connect to the VIDOS Server (File > Connect to server...). You are then prompted to enter your user name and password.

This connection is maintained until you either close the Configuration Manager or disconnect (File > Disconnect from server).

You do not need to use the Configuration Manager installed on the server PC. You can use a Configuration Manager on any other PC, as long as a connection to the server PC can be established via the network.

The connection between a client and the server is established using the Configuration Manager on the client PC. This connection is maintained if the Configuration Manager is closed on the server PC.
Configuration using the Configuration Manager

1. Start the Configuration Manager on any computer in the VIDOS system.
   To do this, click on the icon on the desktop:

2. Select File > Connect to server....
   You will see the Connect to server dialog box:

3. Select the IP address of the server.

4. The first time you start, log in with the following user data:
   User: srvadmin
   Password: vidos

   Note
   Change the password immediately to prevent unauthorized access to the server! See below for details.

5. On the left-hand side of the Configuration Manager screen, select the System tab.

6. In the tree structure, click on Applications > VIDOS Server.
   In the right-hand window, you can access three tabs, which you can use to make all the settings for the connected VIDOS Server.

7. Select the desired tab.

8. After editing a tab, click on Set to save the changes in the system.
User Administration

In the Configuration Manager open the Access tab, as described on page 11. This is where you create user groups and users for the entire VIDOS system:

Groups

Every VIDOS user belongs to a user group. Authorizations are assigned to a user group. If you change the authorizations for a group, this changes the authorizations for all users in the group.
You can set up a maximum of 32 groups containing any number of users.

1. Under **Groups**, click on **Add**. You will see the **Group** dialog box:

   ![Group dialog box](image1)

2. Give the user group a name.

3. Select the **Priority** that you want the group members to have in the system. The higher the inserted number the higher is the priority.

   **Note**
   Users with a higher priority have the right to take over control of a camera from users with lower priority. Incorporating users into a hierarchy of this kind prevents two people from being able to simultaneously control a camera.
4. Assign the desired authorizations to the group. To assign an authorization, click in the box in front of the corresponding entry. A check indicates the actions that the user is permitted to perform.

Select one, several or none of the following authorizations:

<table>
<thead>
<tr>
<th>Authorization</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use VIDOS permissions</td>
<td>If a user group with an identical name has already been created locally on the VIDOS client, this user group retains the authorizations that have been assigned locally under VIDOS. User groups that are not created locally are assigned the authorizations created here.</td>
</tr>
<tr>
<td>Close application</td>
<td>Permitted to exit VIDOS.</td>
</tr>
<tr>
<td>Close full screen</td>
<td>Permitted to close a full screen view. This gives the user – possibly limited – access to VIDOS.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Has access to the Configuration window. This authorization allows editing of site maps, work areas and salvos. The Configuration window still provides access to the local user administration. It is where the initial work area is specified. Work areas and site maps are not saved by the server.</td>
</tr>
<tr>
<td>Connection menu</td>
<td>Has access to the full popup menu for the monitor window. Is authorized to connect cameras and salvos to monitor windows using the popup menu or to break connections. However, it is not possible to make connections using Drag&amp;Drop.</td>
</tr>
<tr>
<td>Modify preset</td>
<td>Permitted to edit presets.</td>
</tr>
<tr>
<td>Recording menu</td>
<td>Has access to the Recording menu.</td>
</tr>
</tbody>
</table>

If you do not select any authorizations, users belonging to this group can only view the predetermined connections. These users only have access to a limited popup menu from the monitor window (e.g. Snapshot, Zoom).

5. Click on OK.

A new user group is created.

6. Click on Set to save the changes in the system.

**Note**

To edit the authorizations, priority or name of a user group, select the corresponding group and then click on Edit.
Users

Once you have created user groups, create users.

1. Under **Users**, click on **Add**.
   
   You will see the **User** dialog box:

   ![User dialog box]

   2. Enter a name for the user.

   3. Enter the password and confirm it.

   **Note**
   
   During authentication, the user must be aware that the user name and password are case sensitive.

   4. Select a user group.

   5. Click on **OK**.
   
   The dialog box is closed. The user is created.

   6. Click on **Set** to save the changes in the system.

   **Note**
   
   To change a user's password or group membership, select the corresponding user and then click on **Edit**.
**User administration information**

You can delete users and user groups. However, if a user is logged into a VIDOS client, he can continue using VIDOS until a new user logs in on that client. It is then no longer possible to log in again as the deleted user.

The user groups **admin** and **servers** cannot be deleted.

A user group can only be deleted if no users belong to it.

The **admin** user group always contains at least one user.

Only users that belong to the **admin** group can edit the server configuration.

A user or user group does not need to be created on a VIDOS client in order to be able to log in there. The entry on the server is sufficient. As soon as a user created on the server logs in on the VIDOS client, the corresponding group and the user are created on the client. The user is created temporarily and the user group is retained.

If you want to connect the VIDOS server to other VIDOS servers, you will need a user belonging to the **servers** group. The user name and password should be entered in the settings for server-server connections.

A backup server expects the user **backup** to exist on the master server.
Server Administration

The VIDOS Server program is also installed on PCs that are integrated into the system as backup or user administration servers:

– Backup server

A backup server replaces the server if it breaks down. Changes made to the configuration for the server are automatically transferred to the backup server.

– User administration server

You can set up a separate server exclusively for central user administration. This user administration server only manages users, not devices. A user administration server can also be backed up by a user administration backup server.

Settings assigned to the respective PC by its role as a backup or user administration server are made on the Server tab. Open this tab in the Configuration Manager as described on page 11:
Server

Lists other VIDOS Server that are integrated into the system in addition to the server currently connected and to which you want this server to connect.

Connected VIDOS clients have access to devices that are set up on one of these servers.

1. Click on **Add**.
   You will see the **Server** dialog box:

2. Enter the URL of the server you want to add. Typically, this is the IP address.
3. Enter the name and password used for this connection.
4. Click on **OK**.
5. Click on **Set** to save the changes in the system.
User administration server

If users are to be centrally managed on a server in a VIDOS system, enter the URL (IP address) of the user administration server here.

If necessary, enter the IP address of the servers that provide a backup for user administration. Leave the corresponding fields blank if you are not using a user administration backup server.

Enter the user name and password. The user must belong to the servers group and be created on the user administration server.

This setting is not made on the user administration server itself. There, the fields remain blank.

Note
Confirm each change and entry you make by clicking on Set. The changes then take effect.
Backup server

A backup server ensures that user data and devices are still available in the system if a main server breaks down or the connection fails.

If the currently connected server itself is used as the master server, these fields remain blank:

If the currently connected server itself is used as the backup server, enter the IP addresses of the PCs for which you want it to act as backup server (Master 1 and Master 2).

For each connection, enter the password for the user backup. The user backup must be created on the master server and belongs to the servers group.

Note
Confirm each change and entry you make by clicking on Set. The changes then take effect.
Logging

Events from VIDOS clients are logged on the server, e.g. camera connections. Server events are also logged.

By default, the MSDE database used for this purpose is installed along with VIDOS Server and is pre-configured for immediate entry of data.

You can change the settings for this database in the Configuration Manager. To do this, open **System > General > Logging**, as described on page 11:

![Configuration Manager](image)

After installation, **vidospro** is entered as the ODBC name and user. The password is **vidos**.

**Note**
Change the password immediately to prevent unauthorized access to the server!

Under *Minimum number of days to keep log entries*, the default value is 0 (zero). This setting means that all logged data is permanently saved.

If you only want the logged data to remain saved for a particular period of time, enter a different figure.

If you do not want to use logging, delete the entries for the ODBC name, user and password. This deactivates logging.
Device Administration

In a VIDOS system, the VIDOS Server is responsible for central device administration. You use the Configuration Manager to add devices to the system, synchronize the settings of several devices and to give or deny users selective access to devices.

**Note**
While you are editing settings for devices, the Configuration Manager should not be started on connected clients or on other servers.
Likewise, the setting pages of the web browser interface for a device should not be accessed simultaneously at any point in the system.

Only the devices that have been added to the system by a server and for which the logged in user has access authorization are displayed on a VIDOS client.

**Device assignment**

1. Start the **Configuration Manager** on any computer in the VIDOS system.
2. Connect to the server (details on page 11).
   - The **Network** list shows all the devices found in the system.
3. If necessary, click on **Refresh**.
4. Select the **Devices** list and then click on **Edit**....
   - You will see the **Device assignment** dialog box.
5. Drag devices you want to be available in the system from the left to the right-hand side of the dialog box using Drag&Drop.

**Note**
For more details, refer to the separate **CONFIGURATION MANAGER** documentation.

6. Click on **OK**.
   - Assigned devices are now displayed on the VIDOS clients.
Privileges

Access to devices is specified separately for each device with reference to each user group.

1. On the left-hand side of the Configuration Manager screen, select the Devices list and select a device.

2. In the right-hand side Configuration Manager window, select the Privileges tab.

   All user groups created on the server are listed in the first column of the table.

3. Place a check in the Device column if you want users from this group to have access to this device.
   Typically, most client users are given access to an NVR.

4. Right click in one of the cells and select the authorization for the respective camera for the respective user group from the popup menu.

5. You can configure entire columns or rows uniformly by clicking in the respective header and selecting the desired setting from the popup menu.

6. Click on Set to save the changes in the system.
The following access privileges can be set for cameras:

<table>
<thead>
<tr>
<th>Color</th>
<th>Privilege</th>
</tr>
</thead>
<tbody>
<tr>
<td>yellow</td>
<td><strong>Live viewing</strong> - Live video data can be displayed.</td>
</tr>
<tr>
<td>green</td>
<td><strong>View and PTZ control</strong> - Video data can be displayed and the camera can be controlled.</td>
</tr>
<tr>
<td>blue</td>
<td><strong>Overrule</strong> - Video data can be displayed and the camera can be controlled. The user with this privilege is given access to the camera even if another user is currently using it exclusively. However, he does not have the option of using the camera exclusively himself. This setting can be used to enable a leading security officer with higher priority to control a camera with precedence over a normal user in case of an alarm, even if the user is actually using that camera exclusively.</td>
</tr>
<tr>
<td>red</td>
<td><strong>No access</strong> - The user group has no access to the respective camera.</td>
</tr>
</tbody>
</table>
Information on Working on the Client

When working on a VIDOS client, note the information listed here.

Local access

The license for a VIDOS client in a server-based system is different than that for a VIDOS installation with no server.

A VIDOS workstation that is integrated into a client/server system only provides limited local access.

If the client is connected to the server (Global settings > Server), local access is only possible by logging in as admin with the corresponding password.

You can log in as the admin user on the client PC to:

- Make any necessary changes to the IP address of the server used
- Create and edit site maps and work areas
- Configure alarm management

Connection information

To find out which server is currently being used, click on Help > About… in VIDOS.

If a server is not available at login, the user is connected to a backup server. If the server breaks down during operation and the system switches to a backup server, members of the admin user group receive a message. Take this message as a cause for checking the availability of the server.
Contacts and Service (Address)

Contact address
Bosch Sicherheitssysteme GmbH
Robert-Koch-Straße 100
85521 Ottobrunn
Germany
E-mail: de.securitysystems@bosch.com
Internet: www.bosch-sicherheitssysteme.de
Service and support

If you have any questions about the programs from the VIDOS Pro Suite, you can find further information on the Internet at:

www.vidos.net

Technical support is available from:

**Americas**
Bosch Security Systems
130 Perinton Parkway
Fairport, New York, 14450, USA
Phone: +1 585 223 4060
Fax: +1 585 223 9180
E-mail: security.sales@us.bosch.com
Internet: www.boschsecurity.us

**Europe, Middle East, Africa**
Bosch Security Systems B.V.
P.O. Box 8000
25600 JB Eindhoven, The Netherlands
Phone: +31 (0)40 27 83955
Fax: +31 (0)40 27 86668
E-mail: emea.securitysystems@bosch.com
Internet: www.boschsecurity.com

**Asia-Pacific**
Bosch Security Systems Pte Ltd
38C Jalan Pemimpin
Singapore 577180
Phone: +65 6319 3450
Fax: +65 6319 3499
E-mail: apr.securitysystems@bosch.com
Internet: www.boschsecurity.com
# Index

| A | Access (tab) | 13 |
| Access authorizations | 27 |
| Access to devices | 26 |
| Activation code | 7 |
| Activation key | 7 |
| admin (user group) | 17 |
| admin (user name) | 10, 29 |
| Authentication code | 7 |
| Authorizations | 13 |
| Close application | 15 |
| Close full screen | 15 |
| Configuration | 15 |
| Connection menu | 15 |
| Modify preset | 15 |
| Recording menu | 15 |
| Use VIDOS permissions | 15 |
| B | backup (user name) | 22 |
| Backup server | 19 |
| C | Configuration Manager | 4 |
| Connection information | 29 |
| Contact address | 31 |
| D | Documentation | 4 |
| additional | 4 |
| I | Installation code | 7 |
| L | License Viewer | 7 |
| Local access | 29 |
| Logging (tab) | 23 |
| N | Network (list) | 25 |
| O | Operating system | 5 |
| P | Priority (authorization) | 14 |
| Privileges (tab) | 26 |
| S | Server (tab) | 19 |
| Server connection | 10 |
| disconnect | 10 |
| establish | 10, 11 |
| Server system | 9 |
| servers (user group) | 17 |
| Service | 32 |
| srvadmin (user name) | 11 |
| Symbols | 3 |
| System (list) | 11 |
| System requirements | 4 |
| U | User administration server | 19 |
| User group | 13 |
| V | VIDOS Pro Suite | 4 |